Pārlūkot izejas kodu

libcrypt-openssl-guess-perl: rename from libcrypt-openssl-guess; enable ptest

We follow Debian naming and this module snuck in misnamed.

Add PROVIDES "libcrypt-openssl-guess" for backwards compatibility.

Add runtime and ptest dependencies.

Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Tim Orling 5 gadi atpakaļ
vecāks
revīzija
30da5aa959

+ 18 - 2
meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess_0.11.bb → meta-perl/recipes-perl/libcrypt/libcrypt-openssl-guess-perl_0.11.bb

@@ -10,12 +10,28 @@ SRC_URI[sha256sum] = "aa6b18e38cb852cbad80a58cd90c395b40819d4d01e0ab37e770314909
 
 DEPENDS += "openssl"
 
-RDEPENDS_${PN}="perl-module-config perl-module-exporter perl-module-symbol perl-module-file-spec"
+RDEPENDS_${PN} = "\
+    perl-module-config \
+    perl-module-exporter \
+    perl-module-extutils-mm \
+    perl-module-extutils-mm-unix \
+    perl-module-file-spec \
+    perl-module-symbol \
+    perl-module-strict \
+    perl-module-warnings \
+"
 
 EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'"
 
 S = "${WORKDIR}/Crypt-OpenSSL-Guess-${PV}"
 
-inherit cpan
+inherit cpan ptest-perl
 
 BBCLASSEXTEND = "native"
+
+# for backwards compatibility
+PROVIDES_${PN} += "libcrypt-openssl-guess"
+
+RDEPENDS_${PN}-ptest += "\
+    perl-module-test-more \
+"