Browse Source

netcf: Fix Manifest not found issue

Fixed:
$ bitbake netcf
WARNING: netcf-0.2.8+gitAUTOINC+2c5d425585-r0 do_package: Manifest /path/sstate-control/manifest-x86_64_x86_64-nativesdk-gnulib.packagedata not found in intel_x86_64 corei7-64 core2-64 x86_64 allarch x86_64_x86_64-nativesdk (variant '')?

This is because gnulib has no related tasks:
do_package[noexec] = "1"
do_packagedata[noexec] = "1"
deltask package_write_ipk
deltask package_write_deb
deltask package_write_rpm
deltask do_deploy_archives

Depends on gnulib:do_populate_sysroot explicitly to fix the problem.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Robert Yang 4 years ago
parent
commit
2754eb92db
1 changed files with 3 additions and 1 deletions
  1. 3 1
      meta-networking/recipes-support/netcf/netcf_0.2.8.bb

+ 3 - 1
meta-networking/recipes-support/netcf/netcf_0.2.8.bb

@@ -14,7 +14,9 @@ SRC_URI = "git://pagure.io/netcf.git;protocol=https \
 
 UPSTREAM_CHECK_GITTAGREGEX = "release-(?P<pver>(\d+(\.\d+)+))"
 
-DEPENDS += "augeas libnl libxslt libxml2 gnulib"
+DEPENDS += "augeas libnl libxslt libxml2"
+
+do_configure[depends] += "gnulib:do_populate_sysroot"
 
 S = "${WORKDIR}/git"