Bläddra i källkod

safec: Update to latest on 3.5.1 release tags

It build fine on mips now.
Musl patch is no longer needed and musl provides memrchr

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 4 år sedan
förälder
incheckning
257f67186c

+ 0 - 30
meta-oe/recipes-core/safec/safec/0001-memrchr-Use-_ISOC11_SOURCE-only-with-glibc.patch

@@ -1,30 +0,0 @@
-From 57456b5d034c8965b11eceed1bf861c98a18c324 Mon Sep 17 00:00:00 2001
-From: "jenkins@kwaj" <jenkins@kwaj>
-Date: Wed, 11 Sep 2019 13:43:45 -0700
-Subject: [PATCH] memrchr: Use _ISOC11_SOURCE only with glibc
-
-this is a glibc feature test macro which is not available
-on other libraries e.g. musl
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/extmem/memrchr_s.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/extmem/memrchr_s.c b/src/extmem/memrchr_s.c
-index 8d10a7b9..e73d3579 100644
---- a/src/extmem/memrchr_s.c
-+++ b/src/extmem/memrchr_s.c
-@@ -36,7 +36,7 @@
- #endif
- 
- #ifdef HAVE_MEMRCHR
--#ifndef _ISOC11_SOURCE
-+#if defined (__GLIBC__) && !defined(_ISOC11_SOURCE)
- extern void *memrchr(const void *, int, size_t);
- #endif
- #endif
--- 
-2.17.1
-

+ 3 - 5
meta-oe/recipes-core/safec/safec_3.5.bb → meta-oe/recipes-core/safec/safec_3.5.1.bb

@@ -7,14 +7,12 @@ SECTION = "lib"
 inherit autotools pkgconfig
 
 S = "${WORKDIR}/git"
-SRCREV = "a99a052a56da409638c9fe7e096a5ae6661ca7cb"
+# v08112019
+SRCREV = "ad76c7b1dbd0403b0c9decf54164fcce271c590f"
 SRC_URI = "git://github.com/rurban/safeclib.git \
-           file://0001-memrchr-Use-_ISOC11_SOURCE-only-with-glibc.patch \
 "
 
-CPPFLAGS_append_libc-musl = " -D_GNU_SOURCE"
-
-COMPATIBLE_HOST = '(x86_64|i.86|powerpc|powerpc64|arm|aarch64).*-linux'
+COMPATIBLE_HOST = '(x86_64|i.86|powerpc|powerpc64|arm|aarch64|mips).*-linux'
 
 PACKAGES =+ "${PN}-check"