Browse Source

srt: add receipe

Secure Reliable Transport (SRT) Protocol

Secure Reliable Transport (SRT) is an open source transport technology that
optimizes streaming performance across unpredictable networks, such as the Internet.

SRT is applied to contribution and distribution endpoints as part of a video
stream workflow to deliver the best quality and lowest latency video at all times.

As audio/video packets are streamed from a source to a destination device,
SRT detects and adapts to the real-time network conditions between the two endpoints.
SRT helps compensate for jitter and bandwidth fluctuations due to congestion
over noisy networks, such as the Internet. Its error recovery mechanism minimizes
the packet loss typical of Internet connections. And SRT supports AES encryption for
end-to-end security, keeping your streams safe from prying eyes.

    * 0001-don-t-install-srt-ffplay.patch
      Upstream-Status: Pending

Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Jose Quaresma 3 years ago
parent
commit
23343cb8e9

+ 28 - 0
meta-multimedia/recipes-support/srt/srt/0001-don-t-install-srt-ffplay.patch

@@ -0,0 +1,28 @@
+From a45b43a2acd4c29bc8a204f51a3fa5e7b9815613 Mon Sep 17 00:00:00 2001
+From: Jose Quaresma <quaresma.jose@gmail.com>
+Date: Sat, 14 Nov 2020 12:29:56 +0000
+Subject: [PATCH] don't install srt-ffplay
+
+srt-ffplay is a simple bash scripts that pipes the output of srt-live-transmit to ffplay.
+It need ffmpeg as dependencie and requeire that libsrt is builded with -DENABLE_APPS=ON.
+So remove it because there are no option to disable the instalation.
+
+Upstream-Status: Pending
+
+Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
+---
+ CMakeLists.txt | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ed6e603..ef53dc5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1224,7 +1224,6 @@ if (ENABLE_UNITTESTS AND ENABLE_CXX11)
+ endif()
+ 
+ 
+-install(PROGRAMS scripts/srt-ffplay DESTINATION ${CMAKE_INSTALL_BINDIR})
+ 
+ 
+ if (DEFINED SRT_EXTRA_APPS_INC)

+ 27 - 0
meta-multimedia/recipes-support/srt/srt_1.4.2.bb

@@ -0,0 +1,27 @@
+SUMMARY = "Secure Reliable Transport (SRT) Protocol"
+DESCRIPTION = "Secure Reliable Transport (SRT) is an open source transport technology \
+that optimizes streaming performance across unpredictable networks, such as the Internet."
+SECTION = "libs"
+HOMEPAGE = "https://github.com/Haivision/srt"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
+
+SRCREV = "50b7af06f3a0a456c172b4cb3aceafa8a5cc0036"
+SRC_URI = "git://github.com/Haivision/srt;protocol=https \
+           file://0001-don-t-install-srt-ffplay.patch \
+           "
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DENABLE_UNITTESTS=OFF"
+
+PACKAGECONFIG ??= "crypt"
+PACKAGECONFIG[debug] = "-DENABLE_DEBUG=1,,"
+PACKAGECONFIG[crypt] = "-DENABLE_ENCRYPTION=ON,-DENABLE_ENCRYPTION=OFF,openssl"
+PACKAGECONFIG[utils] = "-DENABLE_APPS=ON,-DENABLE_APPS=OFF,"
+
+PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'utils', '${PN}-utils', '', d)}"
+FILES_${PN}-utils += "${bindir}"
+RDEPENDS_${PN}-utils += "${PN}"