Browse Source

lvm2: allow for reproducible binary builds

Modify original method to eliminate conditional patching
of configure.ac.  Use SOURCE_DATE_EPOCH which is
required for reproducible binaries.

Signed-off-by: Joe Slater <joe.slater@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Slater, Joseph 3 years ago
parent
commit
1fb6be67b4

+ 10 - 6
meta-oe/recipes-support/lvm2/files/reproducible-build.patch

@@ -1,23 +1,27 @@
 configure.ac:  override CONFIGURE_LINE
 
 For reproducible binaries, we need to report a constant CONFIGURE_LINE.
-This patched is only applied for such builds.
 
-Upstream-Status: Inappropriate [oe specific]
+Upstream-Status: Pending
 
 Signed-off-by: Joe Slater <joe.slater@windriver.com>
 
 
 --- git.orig/configure.ac
 +++ git/configure.ac
-@@ -15,7 +15,10 @@ AC_PREREQ(2.69)
+@@ -15,7 +15,15 @@ AC_PREREQ(2.69)
  ################################################################################
  dnl -- Process this file with autoconf to produce a configure script.
  AC_INIT
 -CONFIGURE_LINE="$0 $@"
-+dnl The default CONFIGURE_LINE has been overridden for reproducible binaries
-+dnl CONFIGURE_LINE="$0 $@"
-+CONFIGURE_LINE="configure parameters are not available for reproducible builds"
++
++dnl per reproducible-builds.org check SOURCE_DATE_EPOCH
++dnl
++if test -z "${SOURCE_DATE_EPOCH+set}" ; then
++    CONFIGURE_LINE="$0 $@"
++else
++    CONFIGURE_LINE="configure options are not available for reproducible builds"
++fi
 +
  AC_CONFIG_SRCDIR([lib/device/dev-cache.h])
  AC_CONFIG_HEADERS([include/configure.h])

+ 1 - 1
meta-oe/recipes-support/lvm2/lvm2.inc

@@ -15,7 +15,7 @@ SRC_URI = "git://sourceware.org/git/lvm2.git \
            file://0001-Avoid-bashisms-in-init-scripts.patch \
            file://0005-do-not-build-manual.patch \
            file://0006-start-lvm2-monitor.service-after-tmp.mount.patch \
-           ${@bb.utils.contains('BUILD_REPRODUCIBLE_BINARIES','1','file://reproducible-build.patch','', d)} \
+           file://reproducible-build.patch \
            "
 
 SRCREV = "b9391b1b9f0b73303fa21f8f92574d17ce4c2b02"