Bladeren bron

linpack_1.0.bb: Add linpack benchmark

The LINPACK Benchmarks are a measure of a system's floating point
computing power. Introduced by Jack Dongarra, they measure how fast a
computer solves a dense n by n system of linear equations Ax = b, which
is a common task in engineering.

https://en.wikipedia.org/wiki/LINPACK_benchmarks

Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Manjukumar Matha 6 jaren geleden
bovenliggende
commit
1d7d2c6855
1 gewijzigde bestanden met toevoegingen van 20 en 0 verwijderingen
  1. 20 0
      meta-oe/recipes-benchmark/linpack/linpack_1.0.bb

+ 20 - 0
meta-oe/recipes-benchmark/linpack/linpack_1.0.bb

@@ -0,0 +1,20 @@
+DESCRIPTION = "LINPACK Benchmarks are a measure of a system's floating point computing power"
+SUMMARY = "LINPACK is a software library for performing numerical linear algebra on digital computers"
+
+LICENSE = "PD"
+LIC_FILES_CHKSUM ="file://${WORKDIR}/linpacknew.c;beginline=1;endline=23;md5=aa025e3bc44190c71e4c5e3b084fed87"
+
+SRC_URI = "http://www.netlib.org/benchmark/linpackc.new;downloadfilename=linpacknew.c"
+SRC_URI[md5sum] = "1c5d0b6a31264685d2e651c920e3cdf4"
+SRC_URI[sha256sum] = "a63f2ec86512959f1fd926bfafb85905b2d7b7402942ffae3af374d48745e97e"
+
+S = "${WORKDIR}"
+
+do_compile () {
+	${CC} ${CFLAGS} ${LDFLAGS} -o linpack linpacknew.c -lm
+}
+
+do_install () {
+	install -Dm 0755 linpack ${D}${bindir}/linpack
+}
+