Преглед на файлове

fontforge: rework for python3

* python3native is necessary because configure asks for version. If it uses
  host's version python modules might be installed in wrong paths
* checked: ${PN}-python is packed properly
* while at it remove uneccessary (wrong) line: there is no ${PN}-python-dbg

Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Andreas Müller преди 4 години
родител
ревизия
1cc86099a8
променени са 1 файла, в които са добавени 3 реда и са изтрити 5 реда
  1. 3 5
      meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb

+ 3 - 5
meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb

@@ -6,10 +6,10 @@ LIC_FILES_CHKSUM = " \
     file://LICENSE;md5=d042f3d2a8fd7208b704a499168e3c89 \
 "
 
-DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash gettext-native"
+DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg libtool uthash gettext-native"
 DEPENDS_append_class-target = " libxi"
 
-inherit autotools pkgconfig pythonnative features_check gettext gtk-icon-cache mime
+inherit autotools pkgconfig python3native features_check gettext gtk-icon-cache mime
 
 REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
 
@@ -31,8 +31,6 @@ EXTRA_OECONF_append_class-native = " with_x=no"
 
 PACKAGES =+ "${PN}-python"
 
-RPROVIDES_${PN}-dbg += "${PN}-python-dbg"
-
 FILES_${PN} += " \
     ${datadir}/appdata \
     ${datadir}/metainfo \
@@ -40,7 +38,7 @@ FILES_${PN} += " \
 "
 
 FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${BPN}/python"
-RDEPENDS_${PN}-python = "python"
+RDEPENDS_${PN}-python = "python3"
 
 # for e.g kde's oxygen-fonts
 BBCLASSEXTEND = "native"