Переглянути джерело

meta-python: rename python2 recipes to python3 eqiuvalent

Rename recipes which were previously built with python2 to their python3
equivalents.

Use new python3 classes (setuptools3) in those recipes.

Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Andrey Zhizhikin 4 роки тому
батько
коміт
1ae3178716

+ 1 - 1
meta-python/recipes-connectivity/python-pyro4/python-pyro4_4.77.bb → meta-python/recipes-connectivity/python-pyro4/python3-pyro4_4.77.bb

@@ -7,7 +7,7 @@ SRC_URI[sha256sum] = "2bfe12a22f396474b0e57c898c7e2c561a8f850bf2055d8cf0f7119f0c
 
 PYPI_PACKAGE = "Pyro4"
 
-inherit pypi setuptools
+inherit pypi setuptools3
 
 RDEPENDS_${PN} += " \
     ${PYTHON_PN}-logging \

+ 1 - 1
meta-python/recipes-connectivity/python-thrift/python-thrift_0.13.0.bb → meta-python/recipes-connectivity/python-thrift/python3-thrift_0.13.0.bb

@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e95cd2f17c70d3180a2b361332319fe0"
 SRC_URI[md5sum] = "c3bc8d9a910d2c9ce26f2ad1f7c96762"
 SRC_URI[sha256sum] = "9af1c86bf73433afc6010ed376a6c6aca2b54099cc0d61895f640870a9ae7d89"
 
-inherit pypi setuptools
+inherit pypi setuptools3
 
 # Use different filename to prevent conflicts with thrift itself
 PYPI_SRC_URI_append = ";downloadfilename=${BP}.${PYPI_PACKAGE_EXT}"

+ 1 - 1
meta-python/recipes-connectivity/python-txws/python-txws_0.9.1.bb → meta-python/recipes-connectivity/python-txws/python3-txws_0.9.1.bb

@@ -11,5 +11,5 @@ SRCREV= "88cf6d9b9b685ffa1720644bd53c742afb10a414"
 
 S = "${WORKDIR}/git"
 
-inherit setuptools
+inherit setuptools3
 

+ 0 - 0
meta-python/recipes-devtools/python-jsonref/python-jsonref_0.2.bb → meta-python/recipes-devtools/python-jsonref/python3-jsonref_0.2.bb


+ 1 - 1
meta-python/recipes-extended/python-cson/python-cson_git.bb → meta-python/recipes-extended/python-cson/python3-cson_git.bb

@@ -15,7 +15,7 @@ S = "${WORKDIR}/git"
 RDEPENDS_${PN}_class-native = ""
 DEPENDS_append_class-native = " python-native "
 
-inherit setuptools
+inherit setuptools3
 
 BBCLASSEXTEND = "native"
 

+ 1 - 1
meta-python/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb → meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.0.bb

@@ -9,7 +9,7 @@ SRC_URI[sha256sum] = "607148429f85412915e32265779c0cf6d09f73aa97cf1ff0d101ac22c6
 
 PYPI_PACKAGE = "ephem"
 
-inherit pypi setuptools
+inherit pypi setuptools3
 
 RDEPENDS_${PN} += "\
     ${PYTHON_PN}-datetime \