ソースを参照

garcon: upgrade 0.7.0 -> 0.8.0

Release notes for 0.8.0
=======================
- fix GarconMenuItem file documentation
- Remove GSourceFunc casts
- Remove GLIB_CHECK_VERSION IFDEFs which are obsolete after glib bump

Release notes for 0.7.3
=======================
[Please note that this is a development release.]

- garcon now needs libxfce4ui/4util 4.15.6+
- Use the symbolic close icon in the error dialog
- Don't launch apps as children
- bump glib (and gio, gthread, etc) minimum to 2.50.0
- relax automake requirement to 1.15
- Add new icon needed for xfce4-about-dialog.
- Translation Updates: Slovenian

Release notes for 0.7.2
=======================
[Please note that this is a development release.]
- Update README.md
- Translation Updates:
  Armenian, Armenian (Armenia), Hebrew, Lithuanian, Occitan
  (post 1500), Uyghur

Release notes for 0.7.1
=======================
[Please note that this is a development release.]

- Drop support for Gtk2
- Drop Gtk3 ifdefs
- Switch to xfce_gtk_image_menu_item
- Add support for GObject Introspection (Fixes #4)
- Improve GObject introspection annotations (Fixes #8)
- Fix missing transfer annotation
- Field codes expansion API update
- Transfer some code to libxfce4util
- Fix default merge rules in xfce-applications.menu (Bug #15504)
- Rename exo-helpers to the new xfce4-xx ones
- Do not add INSTALL in dist tarball
- Fix a memory leak
- Switch to README.md and foreign automake mode
- README: Use table for debug arguments
- Add basic GitLab pipeline
- Translation Updates:
  Albanian, Asturian, Chinese (Hong Kong), Danish, Dutch, Eastern
  Armenian, Estonian, Greek, Hebrew, Indonesian, Interlingue, Norwegian
  Nynorsk, Polish, Portuguese, Uzbek, Uzbek (Latin)

Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Andreas Müller 3 年 前
コミット
189d1c1bfb
1 ファイル変更6 行追加3 行削除
  1. 6 3
      meta-xfce/recipes-xfce/garcon/garcon_0.8.0.bb

+ 6 - 3
meta-xfce/recipes-xfce/garcon/garcon_0.7.0.bb → meta-xfce/recipes-xfce/garcon/garcon_0.8.0.bb

@@ -4,14 +4,17 @@ LICENSE = "LGPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=04a01abcbdabffae1ca26335a293276b"
 DEPENDS = "xfce4-dev-tools-native libxfce4ui intltool-native"
 
-inherit xfce gtk-doc features_check
+inherit xfce gtk-doc gobject-introspection features_check
 
 REQUIRED_DISTRO_FEATURES = "x11"
 
 SRC_URI += "file://0001-xfce-applications.menu-don-t-bloat-settings-menu-by-.patch"
-SRC_URI[md5sum] = "2964c7a7e5d4aac58b4afef9b8602914"
-SRC_URI[sha256sum] = "82c3b61b508011642b09e6fb01b1d3f22c4e4de0fc54a9244327d0ddb66b2423"
+SRC_URI[sha256sum] = "4811d89ee5bc48dbdeffd69fc3eec6c112bbf01fde98a9e848335b374a4aa1bb"
 
 EXTRA_OECONF = "--disable-gtk-doc"
 
+do_compile_prepend() {
+    export GIR_EXTRA_LIBS_PATH="${B}/garcon/.libs"
+}
+
 FILES_${PN} += "${datadir}/desktop-directories"