Browse Source

busybox: create /etc/default on do_install

* Currently, it's blindly assumed that /etc/default
  exists, when busybox-syslog gets copied into it.
  This only works by chance and only if CONFIG_HWCLOCK=y
  is set.

Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Acked-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Andreas Oberritter 12 years ago
parent
commit
143367e4f5
1 changed files with 1 additions and 0 deletions
  1. 1 0
      meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend

+ 1 - 0
meta-oe/recipes-core/busybox/busybox_1.19.3.bbappend

@@ -13,6 +13,7 @@ SYSTEMD_PACKAGES = "${PN}-syslog-systemd"
 SYSTEMD_SERVICE_${PN}-syslog-systemd = "busybox-syslog.service"
 
 do_install_append() {
+	install -d ${D}${sysconfdir}/default
 	install -m 0644 ${WORKDIR}/busybox-syslog.default ${D}${sysconfdir}/default/busybox-syslog
 
 	install -d ${D}${base_libdir}/systemd/system