Browse Source

add image configuration information of Gnome

tianshuliang 3 years ago
parent
commit
10a7ec7caa

+ 26 - 0
meta-gnome/recipes-core/images/core-image-gnome.bb

@@ -0,0 +1,26 @@
+require core-image-minimal-gnome.bb
+
+SUMMARY = "Basic desktop image for ice boards"
+
+IMAGE_FEATURES += "splash package-management x11 ssh-server-openssh \
+                   tools-debug dev-pkgs debug-tweaks"
+
+IMAGE_INSTALL += "gpgme gnupg"
+
+
+# boot to desktop
+SYSTEMD_DEFAULT_TARGET = "graphical.target"
+
+# Gstreamer Packages
+IMAGE_INSTALL += " ffmpeg \
+                   gstreamer1.0 \
+                   gstreamer1.0-plugins-base \
+                   gstreamer1.0-plugins-bad \
+                   gstreamer1.0-plugins-good \
+                   gstreamer1.0-plugins-ugly \
+                   gstreamer1.0-libav \
+                   gstreamer1.0-rtsp-server \
+                   json-glib \
+                   libdaemon \
+                   jansson \
+                   "

+ 21 - 0
meta-gnome/recipes-core/images/core-image-minimal-gnome.bb

@@ -0,0 +1,21 @@
+DESCRIPTION = "A GNOME minimal demo image."
+
+IMAGE_INSTALL += "packagegroup-core-boot \
+    packagegroup-core-x11 \
+    packagegroup-gnome-desktop \
+    weston \
+    packagegroup-core-x11-base \
+    packagegroup-core-x11-xserver \
+    kernel-modules \
+"
+
+inherit features_check
+REQUIRED_DISTRO_FEATURES = "x11"
+
+IMAGE_LINGUAS ?= " "
+
+LICENSE = "MIT"
+
+export IMAGE_BASENAME = "core-image-minimal-gnome"
+
+inherit core-image

+ 1 - 0
meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb

@@ -31,6 +31,7 @@ EXTRA_OECMAKE = " \
     -DENABLE_UOA=OFF \
     -DENABLE_GOOGLE_AUTH=OFF \
     -DENABLE_WEATHER=OFF \
+    -DENABLE_GOOGLE=OFF \
     -DENABLE_INTROSPECTION=${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'ON', 'OFF', d)} \
     -D${LKSTRFTIME} \
     -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \