Browse Source

libgnome-keyring: Force ARM ISA on arm arches <= v5

when global ISA is selected to be thumb then the build
fails since it will use thumb1 on these machines and fails
to compile, it however compiles fine with armv7+ with thumb2
hence limit the fix to armv4/armv5

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Khem Raj 5 years ago
parent
commit
0f162eb8ac
1 changed files with 12 additions and 0 deletions
  1. 12 0
      meta-gnome/recipes-gnome/gnome-keyring/libgnome-keyring_3.12.0.bb

+ 12 - 0
meta-gnome/recipes-gnome/gnome-keyring/libgnome-keyring_3.12.0.bb

@@ -15,3 +15,15 @@ DEPENDS = "dbus libgcrypt glib-2.0 glib-2.0-native intltool-native"
 
 SRC_URI[archive.md5sum] = "6696e4f2e9aed4625cdc3af30bd8c238"
 SRC_URI[archive.sha256sum] = "c4c178fbb05f72acc484d22ddb0568f7532c409b0a13e06513ff54b91e947783"
+
+
+# Fails to build with thumb-1 (qemuarm)
+#| {standard input}: Assembler messages:
+#| {standard input}:823: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#3'
+#| {standard input}:823: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#13'
+#| {standard input}:824: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#29'
+#| {standard input}:824: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#19'
+#| {standard input}:825: Error: lo register required -- `orr r10,r10,r10'
+ARM_INSTRUCTION_SET_armv5 = "arm"
+ARM_INSTRUCTION_SET_armv4 = "arm"
+