Преглед на файлове

tk: export TK_LIBRARY='${libdir}/tk${VER}'

As there is below logic in configure.in
[snip]
test -z "$TK_LIBRARY" && TK_LIBRARY='$(prefix)/lib/tk$(VERSION)'
[snip]

It can make TK_LIBRARY to be $(prefix)/lib/tk$(VERSION)
and then result in some files installed to
/usr/lib/tk8.6 even when ${libdir} actually
extract as /usr/lib64 and there is also a commit
as below adding hack to workaround this.
1ca29d1cd tk: make multilib build compatible and fix library install

Export TK_LIBRARY='${libdir}/tk${VER}' to guarantee
the files installed to the expected places and
also remove the workaround in the previous commit
1ca29d1cd.

Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Mingli Yu преди 5 години
родител
ревизия
008396dbdd
променени са 1 файла, в които са добавени 1 реда и са изтрити 9 реда
  1. 1 9
      meta-oe/recipes-devtools/tcltk/tk_8.6.8.bb

+ 1 - 9
meta-oe/recipes-devtools/tcltk/tk_8.6.8.bb

@@ -45,19 +45,11 @@ EXTRA_OECONF = "\
     --with-tcl=${STAGING_BINDIR}/crossscripts \
     --libdir=${libdir} \
 "
-
+export TK_LIBRARY='${libdir}/tk${VER}'
 do_install_append() {
     ln -sf libtk${VER}.so ${D}${libdir}/libtk${VER}.so.0
     oe_libinstall -so libtk${VER} ${D}${libdir}
     ln -sf wish${VER} ${D}${bindir}/wish
-
-    # Even after passing libdir=${libdir} at config, some incorrect dirs are still generated for the multilib build
-    if [ "$libdir" != "/usr/lib" ]; then
-        # Move files to correct library directory
-        mv ${D}/usr/lib/tk${VER}/* ${D}/${libdir}/tk${VER}/
-        # Remove unneeded/incorrect dir ('usr/lib/')
-        rm -rf ${D}/usr/lib
-    fi
 }
 
 PACKAGECONFIG ??= "xft"