libgcc-external.bb 1.7 KB

1234567891011121314151617181920212223242526272829303132333435
  1. SUMMARY = "The GNU Compiler Collection - libgcc"
  2. HOMEPAGE = "http://www.gnu.org/software/gcc/"
  3. SECTION = "devel"
  4. DEPENDS += "virtual/${TARGET_PREFIX}binutils"
  5. GCC_VERSION := "${@oe.external.run(d, 'gcc', '-dumpversion').rstrip()}"
  6. PV = "${GCC_VERSION}"
  7. inherit external-toolchain
  8. LICENSE = "GPL-3.0-with-GCC-exception"
  9. # libgcc needs libc, but glibc's utilities need libgcc, so short-circuit the
  10. # interdependency here by manually specifying it rather than depending on the
  11. # libc packagedata.
  12. RDEPENDS_${PN} += "${TCLIBC}"
  13. INSANE_SKIP_${PN} += "build-deps"
  14. external_libroot = "${@os.path.realpath('${EXTERNAL_TOOLCHAIN_LIBROOT}').replace(os.path.realpath('${EXTERNAL_TOOLCHAIN}') + '/', '/')}"
  15. FILES_MIRRORS =. "${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/|${external_libroot}/\n"
  16. FILES_${PN} = "${base_libdir}/libgcc_s.so.*"
  17. FILES_${PN}-dev = "${base_libdir}/libgcc_s.so \
  18. ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtbegin.o \
  19. ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtbeginS.o \
  20. ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtbeginT.o \
  21. ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtend.o \
  22. ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtendS.o \
  23. ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtfastmath.o \
  24. ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtprec*.o \
  25. ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/libgcc.a \
  26. ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/libgcc_eh.a \
  27. ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/include/unwind.h \
  28. ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/libgcov.a \
  29. "
  30. INSANE_SKIP_${PN}-dev += "staticdev"