Browse Source

Various: use external_run, not oe.external.run

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Christopher Larson 6 years ago
parent
commit
e5885f2319

+ 2 - 2
classes/external-common.bbclass

@@ -1,8 +1,8 @@
 OE_IMPORTS += "oe.external"
 OE_IMPORTED := "${@oe_import(d)}"
 
-EXTERNAL_TOOLCHAIN_SYSROOT ?= "${@oe.external.run(d, 'gcc', *(TARGET_CC_ARCH.split() + ['-print-sysroot'])).rstrip()}"
-EXTERNAL_TOOLCHAIN_LIBROOT ?= "${@oe.external.run(d, 'gcc', *(TARGET_CC_ARCH.split() + ['-print-file-name=crtbegin.o'])).rstrip().replace('/crtbegin.o', '')}"
+EXTERNAL_TOOLCHAIN_SYSROOT ?= "${@external_run(d, 'gcc', *(TARGET_CC_ARCH.split() + ['-print-sysroot'])).rstrip()}"
+EXTERNAL_TOOLCHAIN_LIBROOT ?= "${@external_run(d, 'gcc', *(TARGET_CC_ARCH.split() + ['-print-file-name=crtbegin.o'])).rstrip().replace('/crtbegin.o', '')}"
 EXTERNAL_LIBC_KERNEL_VERSION ?= "${@external_get_kernel_version("${EXTERNAL_TOOLCHAIN_SYSROOT}${prefix}")}"
 
 EXTERNAL_INSTALL_SOURCE_PATHS = "\

+ 1 - 1
recipes-external/binutils/binutils-external-cross.bb

@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.gnu.org/software/binutils/"
 BUGTRACKER = "http://sourceware.org/bugzilla/"
 SECTION = "devel"
 PN .= "-${TARGET_ARCH}"
-PV := "${@oe.external.run(d, 'ld', '-v').splitlines()[0].split()[-1].rstrip()}"
+PV := "${@external_run(d, 'ld', '-v').splitlines()[0].split()[-1].rstrip()}"
 LICENSE = "${@'GPLv3' if '${PV}'.split('.') > '2.17.50.0.12'.split('.') else 'GPLv2'}"
 
 PROVIDES += "virtual/${TARGET_PREFIX}binutils"

+ 1 - 1
recipes-external/gcc/gcc-external.inc

@@ -1,7 +1,7 @@
 SUMMARY = "The GNU Compiler Collection"
 HOMEPAGE = "http://www.gnu.org/software/gcc/"
 SECTION = "devel"
-GCC_VERSION := "${@oe.external.run(d, 'gcc', '-dumpversion').rstrip()}"
+GCC_VERSION := "${@external_run(d, 'gcc', '-dumpversion').rstrip()}"
 PV = "${GCC_VERSION}"
 
 inherit external-toolchain

+ 2 - 2
recipes-external/gcc/gcc-runtime-external.bb

@@ -1,4 +1,4 @@
-GCC_VERSION := "${@oe.external.run(d, 'gcc', '-dumpversion').rstrip()}"
+GCC_VERSION := "${@external_run(d, 'gcc', '-dumpversion').rstrip()}"
 PV = "${GCC_VERSION}"
 BINV = "${GCC_VERSION}"
 
@@ -18,7 +18,7 @@ python () {
 }
 
 target_libdir = "${libdir}"
-HEADERS_MULTILIB_SUFFIX ?= "${@oe.external.run(d, 'gcc', *('${TARGET_CC_ARCH}'.split() + ['-print-sysroot-headers-suffix'])).rstrip()}"
+HEADERS_MULTILIB_SUFFIX ?= "${@external_run(d, 'gcc', *('${TARGET_CC_ARCH}'.split() + ['-print-sysroot-headers-suffix'])).rstrip()}"
 external_libroot = "${@os.path.realpath('${EXTERNAL_TOOLCHAIN_LIBROOT}').replace(os.path.realpath('${EXTERNAL_TOOLCHAIN}') + '/', '/')}"
 FILES_MIRRORS =. "\
     ${libdir}/gcc/${TARGET_SYS}/${BINV}/|${external_libroot}/\n \

+ 1 - 1
recipes-external/gcc/gcc-sanitizers-external.bb

@@ -1,4 +1,4 @@
-GCC_VERSION := "${@oe.external.run(d, 'gcc', '-dumpversion').rstrip()}"
+GCC_VERSION := "${@external_run(d, 'gcc', '-dumpversion').rstrip()}"
 PV = "${GCC_VERSION}"
 BINV = "${GCC_VERSION}"
 

+ 1 - 1
recipes-external/gcc/libgcc-external.bb

@@ -2,7 +2,7 @@ SUMMARY = "The GNU Compiler Collection - libgcc"
 HOMEPAGE = "http://www.gnu.org/software/gcc/"
 SECTION = "devel"
 DEPENDS += "virtual/${TARGET_PREFIX}binutils"
-GCC_VERSION := "${@oe.external.run(d, 'gcc', '-dumpversion').rstrip()}"
+GCC_VERSION := "${@external_run(d, 'gcc', '-dumpversion').rstrip()}"
 PV = "${GCC_VERSION}"
 
 inherit external-toolchain

+ 1 - 1
recipes-external/gcc/libgfortran-external.bb

@@ -1,7 +1,7 @@
 SUMMARY = "The GNU Compiler Collection - libgfortran"
 HOMEPAGE = "http://www.gnu.org/software/gcc/"
 SECTION = "devel"
-GCC_VERSION := "${@oe.external.run(d, 'gcc', '-dumpversion').rstrip()}"
+GCC_VERSION := "${@external_run(d, 'gcc', '-dumpversion').rstrip()}"
 PV = "${GCC_VERSION}"
 
 inherit external-toolchain

+ 2 - 2
recipes-external/gdb/gdbserver-external.bb

@@ -1,12 +1,12 @@
 SUMMARY = "gdbserver is a program that allows you to run GDB on a different machine than the one which is running the program being debugged"
 HOMEPAGE = "http://www.gnu.org/software/gdb/"
 SECTION = "devel"
-PV := "${@oe.external.run(d, 'gdb', '-v').splitlines()[0].split()[-1]}"
+PV := "${@external_run(d, 'gdb', '-v').splitlines()[0].split()[-1]}"
 
 inherit external-toolchain
 
 def get_gdb_license(d):
-    output = oe.external.run(d, 'gdb', '-v')
+    output = external_run(d, 'gdb', '-v')
     if output != 'UNKNOWN':
         for line in output.splitlines():
             if line.startswith('License '):