Browse Source

libgcc-external: avoid blowing up for a non-external tcmode

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Christopher Larson 3 years ago
parent
commit
ddd87efb3b
1 changed files with 6 additions and 0 deletions
  1. 6 0
      recipes-external/gcc/libgcc-external.bb

+ 6 - 0
recipes-external/gcc/libgcc-external.bb

@@ -31,11 +31,17 @@ FILES_${PN}-dbg += "${base_libdir}/.debug/libgcc_s.so.*.debug"
 # Follow any symlinks in the libroot (multilib build) to the main
 # libroot and include any symlinks there that link to our libroot.
 python add_ml_symlink () {
+    pass
+}
+python add_ml_symlink_tcmode-external () {
     import pathlib
 
     def get_links(p):
         return (c for c in p.iterdir() if c.is_symlink())
 
+    if not d.getVar('EXTERNAL_TOOLCHAIN'):
+        return
+
     libroot = d.getVar('EXTERNAL_TOOLCHAIN_LIBROOT')
     if libroot != 'UNKNOWN':
         sysroot = pathlib.Path(d.getVar('EXTERNAL_TOOLCHAIN_SYSROOT')).resolve()