Browse Source

Add missing expand flags

This is needed to work with the changes coming from Richard soon. See poky's
master-next.

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Christopher Larson 8 years ago
parent
commit
dae69118e3

+ 1 - 1
classes/common-license.bbclass

@@ -43,7 +43,7 @@ def mapped_license(license, d):
     if license.endswith('+'):
         license = license[:-1]
 
-    mapped = d.getVarFlag('SPDXLICENSEMAP', license)
+    mapped = d.getVarFlag('SPDXLICENSEMAP', license, False)
     if mapped:
         license = mapped
     return license

+ 1 - 1
classes/external-toolchain.bbclass

@@ -58,7 +58,7 @@ python () {
         return
 
     # We're not an available provider if there's no external toolchain
-    if not d.getVar("EXTERNAL_TOOLCHAIN"):
+    if not d.getVar("EXTERNAL_TOOLCHAIN", True):
         raise bb.parse.SkipPackage("External toolchain not configured (EXTERNAL_TOOLCHAIN not set).")
 
     if not oe.data.typed_value('EXTERNAL_AUTO_PROVIDE', d):

+ 2 - 2
recipes-external/glibc/glibc-sourcery.bb

@@ -98,9 +98,9 @@ require recipes-external/glibc/glibc-sysroot-setup.inc
 require recipes-external/glibc/glibc-package-adjusted.inc
 
 python () {
-    if not d.getVar("EXTERNAL_TOOLCHAIN"):
+    if not d.getVar("EXTERNAL_TOOLCHAIN", True):
         raise bb.parse.SkipPackage("External toolchain not configured (EXTERNAL_TOOLCHAIN not set).")
 
-    if not d.getVar("SOURCERY_SRC_URI"):
+    if not d.getVar("SOURCERY_SRC_URI", True):
         raise bb.parse.SkipPackage("glibc-sourcery requires that SOURCERY_SRC_URI point to the sourcery source tarball")
 }