Przeglądaj źródła

libgcc-external: disable the file-rdeps check

We need to disable this for the same reason we disable the build-deps check.
The recursive dependency between libgcc and glibc has to be broken.

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Christopher Larson 6 lat temu
rodzic
commit
b3840c6d56
1 zmienionych plików z 2 dodań i 2 usunięć
  1. 2 2
      recipes-external/gcc/libgcc-external.bb

+ 2 - 2
recipes-external/gcc/libgcc-external.bb

@@ -12,8 +12,8 @@ LICENSE = "GPL-3.0-with-GCC-exception"
 # libgcc needs libc, but glibc's utilities need libgcc, so short-circuit the
 # interdependency here by manually specifying it rather than depending on the
 # libc packagedata.
-RDEPENDS_${PN} += "${TCLIBC}"
-INSANE_SKIP_${PN} += "build-deps"
+RDEPENDS_${PN} += "${@'${PREFERRED_PROVIDER_virtual/libc}' if '${PREFERRED_PROVIDER_virtual/libc}' else '${TCLIBC}'}"
+INSANE_SKIP_${PN} += "build-deps file-rdeps"
 
 external_libroot = "${@os.path.realpath('${EXTERNAL_TOOLCHAIN_LIBROOT}').replace(os.path.realpath('${EXTERNAL_TOOLCHAIN}') + '/', '/')}"
 FILES_MIRRORS =. "${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/|${external_libroot}/\n"