Browse Source

libgcc-external: drop the static files that won't be found anyway

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Serge Semin 6 years ago
parent
commit
88a717a4e8
1 changed files with 4 additions and 14 deletions
  1. 4 14
      recipes-external/gcc/libgcc-external.bb

+ 4 - 14
recipes-external/gcc/libgcc-external.bb

@@ -15,22 +15,12 @@ LICENSE = "GPL-3.0-with-GCC-exception"
 RDEPENDS_${PN} += "${@'${PREFERRED_PROVIDER_virtual/libc}' if '${PREFERRED_PROVIDER_virtual/libc}' else '${TCLIBC}'}"
 INSANE_SKIP_${PN} += "build-deps file-rdeps"
 
-external_libroot = "${@os.path.realpath('${EXTERNAL_TOOLCHAIN_LIBROOT}').replace(os.path.realpath('${EXTERNAL_TOOLCHAIN}') + '/', '/')}"
-FILES_MIRRORS =. "${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/|${external_libroot}/\n"
-
+# The dynamically loadable files belong to libgcc, since we really don't need the static files
+# on the target, moreover linker won't be able to find them there (see original libgcc.bb recipe).
+BINV = "${GCC_VERSION}"
 FILES_${PN} = "${base_libdir}/libgcc_s.so.*"
 FILES_${PN}-dev = "${base_libdir}/libgcc_s.so \
-                   ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtbegin.o \
-                   ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtbeginS.o \
-                   ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtbeginT.o \
-                   ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtend.o \
-                   ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtendS.o \
-                   ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtfastmath.o \
-                   ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/crtprec*.o \
-                   ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/libgcc.a \
-                   ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/libgcc_eh.a \
-                   ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/include/unwind.h \
-                   ${libdir}/gcc/${TARGET_SYS}/${GCC_VERSION}/libgcov.a \
+                   ${libdir}/${EXTERNAL_TARGET_SYS}/${BINV}* \
                    "
 INSANE_SKIP_${PN}-dev += "staticdev"
 FILES_${PN}-dbg += "${base_libdir}/.debug/libgcc_s.so.*.debug"