Browse Source

glibc-external: obey a locale-utf8-is-default external toolchain feature

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Christopher Larson 3 years ago
parent
commit
6b29ed97ea
1 changed files with 2 additions and 1 deletions
  1. 2 1
      recipes-external/glibc/glibc-external.bb

+ 2 - 1
recipes-external/glibc/glibc-external.bb

@@ -53,7 +53,8 @@ FILES_MIRRORS .= "\
 python do_install () {
     bb.build.exec_func('external_toolchain_do_install', d)
     bb.build.exec_func('glibc_external_do_install_extra', d)
-    bb.build.exec_func('adjust_locale_names', d)
+    if not bb.utils.contains('EXTERNAL_TOOLCHAIN_FEATURES', 'locale-utf8-is-default', True, False, d):
+        bb.build.exec_func('adjust_locale_names', d)
     # sentinel
 }