Browse Source

libnsl2: depend on libtirpc

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Christopher Larson 3 years ago
parent
commit
2d5738a7e5
1 changed files with 5 additions and 1 deletions
  1. 5 1
      recipes-external/libnsl/libnsl2-external.bb

+ 5 - 1
recipes-external/libnsl/libnsl2-external.bb

@@ -14,9 +14,13 @@ FILES_${PN} = "${libdir}/libnsl*.so.* ${libdir}/libnsl-*.so"
 FILES_${PN}-dev = "${libdir}/libnsl.so ${includedir}/rpcsvc/nis*.h ${includedir}/rpcsvc/yp*.h"
 FILES_${PN}-staticdev = "${libdir}/libnsl.a"
 
-libc_rdep = "${@'${PREFERRED_PROVIDER_virtual/libc}' if '${PREFERRED_PROVIDER_virtual/libc}' else '${TCLIBC}'}"
+libc_rdep = "${@'${PREFERRED_PROVIDER_virtual/libc}' if d.getVar('PREFERRED_PROVIDER_virtual/libc') else '${TCLIBC}'}"
 RDEPENDS_${PN} += "${libc_rdep}"
 
+# Default to avoid parsing issue
+PREFERRED_PROVIDER_libtirpc ?= "libtirpc"
+RDEPENDS_${PN} += "${PREFERRED_PROVIDER_libtirpc}"
+
 do_install_extra () {
     # Depending on whether this comes from the standalone libnsl2 or glibc, the
     # soname may vary, hence covering both 1 and 2, and it may be installed in