Pārlūkot izejas kodu

libgcc-external: fix the resolved relative path

This was using the relpath between the sysroot and the libroot, but only
resolved one of the two, which would result in a wildly incorrect
relative path, breaking the build in some contexts.

JIRA: SB-15645

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Christopher Larson 3 gadi atpakaļ
vecāks
revīzija
217f6de212
1 mainītis faili ar 1 papildinājumiem un 1 dzēšanām
  1. 1 1
      recipes-external/gcc/libgcc-external.bb

+ 1 - 1
recipes-external/gcc/libgcc-external.bb

@@ -19,7 +19,7 @@ INSANE_SKIP_${PN} += "build-deps file-rdeps"
 # on the target, moreover linker won't be able to find them there (see original libgcc.bb recipe).
 BINV = "${GCC_VERSION}"
 FILES_${PN} = "${base_libdir}/libgcc_s.so.*"
-LIBROOT_RELATIVE_RESOLVED = "${@os.path.relpath(os.path.realpath('${EXTERNAL_TOOLCHAIN_LIBROOT}'), '${EXTERNAL_TOOLCHAIN_SYSROOT}')}"
+LIBROOT_RELATIVE_RESOLVED = "${@os.path.relpath(os.path.realpath('${EXTERNAL_TOOLCHAIN_LIBROOT}'), os.path.realpath('${EXTERNAL_TOOLCHAIN_SYSROOT}'))}"
 LIBROOT_RELATIVE = "${@os.path.relpath('${EXTERNAL_TOOLCHAIN_LIBROOT}', '${EXTERNAL_TOOLCHAIN_SYSROOT}')}"
 FILES_${PN}-dev = "${base_libdir}/libgcc_s.so \
              /${LIBROOT_RELATIVE_RESOLVED} \