Sfoglia il codice sorgente

binutils-external-cross: split out binutils-external.inc

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Christopher Larson 6 anni fa
parent
commit
0e591ee96f

+ 2 - 10
recipes-external/binutils/binutils-external-cross.bb

@@ -1,18 +1,10 @@
+require recipes-external/binutils/binutils-external.inc
 inherit external-toolchain-cross
 
-SUMMARY = "GNU binary utilities"
-HOMEPAGE = "http://www.gnu.org/software/binutils/"
-BUGTRACKER = "http://sourceware.org/bugzilla/"
-SECTION = "devel"
 PN .= "-${TARGET_ARCH}"
-PV := "${@external_run(d, 'ld', '-v').splitlines()[0].split()[-1].rstrip()}"
-LICENSE = "${@'GPLv3' if '${PV}'.split('.') > '2.17.50.0.12'.split('.') else 'GPLv2'}"
-
 PROVIDES += "virtual/${TARGET_PREFIX}binutils"
 
-EXTERNAL_CROSS_BINARIES = "ar as ld nm objcopy objdump ranlib strip \
-                           addr2line c++filt elfedit gprof readelf size \
-                           strings"
+EXTERNAL_CROSS_BINARIES = "${binutils_binaries}"
 
 do_install_append () {
     if [ ! -e ${D}${bindir}/${TARGET_PREFIX}ld.bfd ]; then

+ 10 - 0
recipes-external/binutils/binutils-external.inc

@@ -0,0 +1,10 @@
+SUMMARY = "GNU binary utilities"
+HOMEPAGE = "http://www.gnu.org/software/binutils/"
+BUGTRACKER = "http://sourceware.org/bugzilla/"
+SECTION = "devel"
+PV := "${@external_run(d, 'ld', '-v').splitlines()[0].split()[-1].rstrip()}"
+LICENSE = "${@'GPLv3' if '${PV}'.split('.') > '2.17.50.0.12'.split('.') else 'GPLv2'}"
+
+binutils_binaries = "ar as ld nm objcopy objdump ranlib strip \
+                     addr2line c++filt elfedit gprof readelf size \
+                     strings"