Quellcode durchsuchen

gdbserver-external: add missing MLPREFIX in dep on compilerlibs

DEPENDS/PROVIDES & PREFERRED_PROVIDER get mapped for mlprefix
automatically, but 'depends' flags do not, so the MLPREFIX has to be
explicit in such flags. This fixes the ability to build multilib images,
i.e. lib32-core-image-base.

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Christopher Larson vor 5 Jahren
Ursprung
Commit
074bea89db
1 geänderte Dateien mit 1 neuen und 1 gelöschten Zeilen
  1. 1 1
      recipes-external/gdb/gdbserver-external.bb

+ 1 - 1
recipes-external/gdb/gdbserver-external.bb

@@ -24,5 +24,5 @@ FILES_${PN}-doc = "${mandir}/man1/gdbserver.1"
 # Ensure that our rdeps are able to be set by shlibs processing
 do_package[depends] += "\
     virtual/libc:do_packagedata \
-    virtual/${TARGET_PREFIX}compilerlibs:do_packagedata \
+    virtual/${MLPREFIX}${TARGET_PREFIX}compilerlibs:do_packagedata \
 "