Browse Source

fix mesa complie error

tianshuliang 3 years ago
parent
commit
b52353f76a
1 changed files with 6 additions and 9 deletions
  1. 6 9
      recipes-graphics/mesa/mesa_20.2.1.bbappend

+ 6 - 9
recipes-graphics/mesa/mesa_20.2.1.bbappend

@@ -1,13 +1,10 @@
 SUMMARY = "A free implementation of the OpenGL API"
 
-do_compile() {
-	    echo "${SUMMARY}->do_compile: Nothing to do!!"
-}       
- 
-do_install() {
-	    echo "${SUMMARY}->do_install: Nothing to do!!"
+do_compile_prepend() {
+    if [ -f ${WORKDIR}/${PN}-${PV}/meson.build ]; then
+        sed -i "s|pre_args += '-DUSE_ELF_TLS'|#pre_args += '-DUSE_ELF_TLS'|g"  ${WORKDIR}/${PN}-${PV}/meson.build
+        sed -i "s|use_elf_tls = true|#use_elf_tls = true|g"  ${WORKDIR}/${PN}-${PV}/meson.build
+    fi
+
 }       
  
-do_install_append() {
-	    echo "${SUMMARY}->do_install_append: Nothing to do!!"
-}