llvm.spec 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. Name: LLVM
  2. Version: 9.0.0
  3. Release: 0
  4. Summary: LLVM (An Optimizing Compiler Infrastructure)
  5. License: Apache-2.0 with LLVM exception
  6. Vendor: None (open source)
  7. Group: Development/Compilers
  8. URL: http://llvm..org/
  9. Source: http://llvm.org/releases/9.0.0/LLVM-9.0.0.tar.gz
  10. BuildRoot: %{_tmppath}/%{name}-root
  11. Requires: /sbin/ldconfig
  12. BuildRequires: gcc >= 3.4
  13. %description
  14. LLVM is a compiler infrastructure designed for compile-time, link-time, runtime,
  15. and idle-time optimization of programs from arbitrary programming languages.
  16. LLVM is written in C++ and has been developed since 2000 at the University of
  17. Illinois and Apple. It currently supports compilation of C and C++ programs,
  18. using front-ends derived from GCC 4.0.1. A new front-end for the C family of
  19. languages is in development. The compiler infrastructure
  20. includes mirror sets of programming tools as well as libraries with equivalent
  21. functionality.
  22. %prep
  23. %setup -q -n LLVM-9.0.0
  24. %build
  25. ./configure \
  26. --prefix=%{_prefix} \
  27. --bindir=%{_bindir} \
  28. --datadir=%{_datadir} \
  29. --includedir=%{_includedir} \
  30. --libdir=%{_libdir} \
  31. --enable-optimized \
  32. --enable-assertions
  33. make tools-only
  34. %install
  35. rm -rf %{buildroot}
  36. make install DESTDIR=%{buildroot}
  37. %clean
  38. rm -rf %{buildroot}
  39. %post -p /sbin/ldconfig
  40. %postun -p /sbin/ldconfig
  41. %files
  42. %defattr(-, root, root)
  43. %doc CREDITS.TXT LICENSE.TXT README.txt docs/*.{html,css,gif,jpg} docs/CommandGuide
  44. %{_bindir}/*
  45. %{_libdir}/*.o
  46. %{_libdir}/*.a
  47. %{_libdir}/*.so
  48. %{_includedir}/llvm
  49. %changelog
  50. * Fri Aug 04 2006 Reid Spencer
  51. - Updates for release 1.8
  52. * Fri Apr 07 2006 Reid Spencer
  53. - Make the build be optimized+assertions
  54. * Fri May 13 2005 Reid Spencer
  55. - Minor adjustments for the 1.5 release
  56. * Mon Feb 09 2003 Brian R. Gaeke
  57. - Initial working version of RPM spec file.