qemu-system-native_7.2.0.bb 1.2 KB

123456789101112131415161718192021222324252627282930313233
  1. BPN = "qemu"
  2. inherit python3-dir
  3. require qemu-native.inc
  4. # As some of the files installed by qemu-native and qemu-system-native
  5. # are the same, we depend on qemu-native to get the full installation set
  6. # and avoid file clashes
  7. DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native bison-native meson-native ninja-native"
  8. EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}"
  9. PACKAGECONFIG ??= "fdt alsa kvm pie slirp \
  10. ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer epoxy', '', d)} \
  11. "
  12. # Handle distros such as CentOS 5 32-bit that do not have kvm support
  13. PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
  14. do_install:append() {
  15. install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
  16. # The following is also installed by qemu-native
  17. rm -f ${D}${datadir}/qemu/trace-events-all
  18. rm -rf ${D}${datadir}/qemu/keymaps
  19. rm -rf ${D}${datadir}/icons/
  20. rm -rf ${D}${includedir}/qemu-plugin.h
  21. # Install qmp.py to be used with testimage
  22. install -d ${D}${libdir}/qemu-python/qmp/
  23. install -D ${S}/python/qemu/qmp/* ${D}${libdir}/qemu-python/qmp/
  24. }