qemu-helper-native_1.0.bb 746 B

1234567891011121314151617181920212223242526272829
  1. SUMMARY = "Helper utilities needed by the runqemu script"
  2. LICENSE = "GPL-2.0-only"
  3. RDEPENDS:${PN} = "qemu-system-native"
  4. PR = "r1"
  5. LIC_FILES_CHKSUM = "file://${WORKDIR}/tunctl.c;endline=4;md5=ff3a09996bc5fff6bc5d4e0b4c28f999"
  6. SRC_URI = "\
  7. file://tunctl.c \
  8. file://qemu-oe-bridge-helper.c \
  9. "
  10. S = "${WORKDIR}"
  11. inherit native
  12. do_compile() {
  13. ${CC} ${CFLAGS} ${LDFLAGS} -Wall tunctl.c -o tunctl
  14. ${CC} ${CFLAGS} ${LDFLAGS} -Wall qemu-oe-bridge-helper.c -o qemu-oe-bridge-helper
  15. }
  16. do_install() {
  17. install -d ${D}${bindir}
  18. install tunctl ${D}${bindir}/
  19. install qemu-oe-bridge-helper ${D}${bindir}/
  20. }
  21. DEPENDS += "qemu-system-native unfs3-native pseudo-native"
  22. addtask addto_recipe_sysroot after do_populate_sysroot before do_build