nodejs-oe-cache-native_18.0.bb 487 B

123456789101112131415161718192021
  1. DESCRIPTION = "OE helper for manipulating npm cache"
  2. LICENSE = "Apache-2.0"
  3. LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
  4. SRC_URI = "\
  5. file://oe-npm-cache \
  6. "
  7. inherit native
  8. B = "${WORKDIR}/build"
  9. do_configure() {
  10. sed -e 's!@@libdir@@!${libdir}!g' < '${WORKDIR}/oe-npm-cache' > '${B}/oe-npm-cache'
  11. }
  12. do_install() {
  13. install -D -p -m 0755 ${B}/oe-npm-cache ${D}${bindir}/oe-npm-cache
  14. }
  15. RDEPENDS:${PN} = "nodejs-native"