gdb_13.2.bb 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. require gdb-common.inc
  2. inherit gettext pkgconfig
  3. #LDFLAGS:append = " -s"
  4. #export CFLAGS:append=" -L${STAGING_LIBDIR}"
  5. # cross-canadian must not see this
  6. PACKAGES =+ "gdbserver"
  7. FILES:gdbserver = "${bindir}/gdbserver"
  8. require gdb.inc
  9. inherit python3-dir
  10. EXTRA_OEMAKE:append:libc-musl = "\
  11. gt_cv_func_gnugettext1_libc=yes \
  12. gt_cv_func_gnugettext2_libc=yes \
  13. gl_cv_func_working_strerror=yes \
  14. gl_cv_func_strerror_0_works=yes \
  15. gl_cv_func_gettimeofday_clobber=no \
  16. "
  17. do_configure:prepend() {
  18. if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
  19. cat > ${WORKDIR}/python << EOF
  20. #!/bin/sh
  21. case "\$2" in
  22. --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
  23. --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
  24. --exec-prefix) echo "${exec_prefix}" ;;
  25. *) exit 1 ;;
  26. esac
  27. exit 0
  28. EOF
  29. chmod +x ${WORKDIR}/python
  30. fi
  31. }