gcc_12.2.bb 800 B

1234567891011121314
  1. require recipes-devtools/gcc/gcc-${PV}.inc
  2. require gcc-target.inc
  3. # Building with thumb enabled on armv4t armv5t fails with
  4. # | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
  5. # | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
  6. ARM_INSTRUCTION_SET:armv4 = "arm"
  7. ARM_INSTRUCTION_SET:armv5 = "arm"
  8. ARMFPARCHEXT:armv6 = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
  9. ARMFPARCHEXT:armv7a = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
  10. ARMFPARCHEXT:armv7ve = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
  11. BBCLASSEXTEND = "nativesdk"