dubhe-image-initramfs.bb 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Simple initramfs image. Mostly used for live images.
  2. DESCRIPTION = "Small image capable of booting a device. The kernel includes \
  3. the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
  4. first 'init' program more efficiently."
  5. INITRAMFS_SCRIPTS ?= "\
  6. initramfs-boot \
  7. packagegroup-core-boot \
  8. "
  9. PACKAGE_INSTALL = "\
  10. ${INITRAMFS_SCRIPTS} \
  11. ${VIRTUAL-RUNTIME_base-utils} \
  12. base-passwd \
  13. ${ROOTFS_BOOTSTRAP_INSTALL} \
  14. packagegroup-starfive-essentials \
  15. packagegroup-starfive-dubhe-essentials \
  16. "
  17. TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"
  18. # Do not pollute the initrd image with rootfs features
  19. IMAGE_FEATURES = ""
  20. export IMAGE_BASENAME = "dubhe-image-initramfs"
  21. IMAGE_NAME_SUFFIX ?= ""
  22. IMAGE_LINGUAS = "en-us"
  23. GLIBC_GENERATE_LOCALES = "en_US.UTF-8"
  24. LICENSE = "MIT"
  25. IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
  26. inherit core-image
  27. IMAGE_ROOTFS_SIZE = "8192"
  28. IMAGE_ROOTFS_EXTRA_SPACE = "0"
  29. EXTRA_IMAGEDEPENDS ?= ""
  30. # Use the same restriction as initramfs-module-install
  31. COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*|riscv64.*|rv64.*)-(linux.*|freebsd.*)'
  32. # Override this as the qspi-image will populate the sdk_ext
  33. do_populate_sdk_ext () {
  34. }