ldconfig-native_2.12.1.bb 1.0 KB

123456789101112131415161718192021222324252627282930313233343536
  1. SUMMARY = "A standalone native ldconfig build"
  2. LICENSE = "GPL-2.0-or-later"
  3. LIC_FILES_CHKSUM = "file://${S}/ldconfig.c;endline=17;md5=1d15f20937c055cb5de2329a4c054399"
  4. SRC_URI = "file://ldconfig-native-2.12.1.tar.bz2 \
  5. file://ldconfig.patch \
  6. file://ldconfig_aux-cache_path_fix.patch \
  7. file://32and64bit.patch \
  8. file://endian-ness_handling.patch \
  9. file://flag_fix.patch \
  10. file://endianess-header.patch \
  11. file://ldconfig-default-to-all-multilib-dirs.patch \
  12. file://endian-ness_handling_fix.patch \
  13. file://add-64-bit-flag-for-ELF64-entries.patch \
  14. file://no-aux-cache.patch \
  15. file://add-riscv-support.patch \
  16. "
  17. PR = "r2"
  18. FILESEXTRAPATHS =. "${FILE_DIRNAME}/${P}:"
  19. inherit native
  20. S = "${WORKDIR}/${PN}-${PV}"
  21. do_compile () {
  22. $CC ldconfig.c -std=gnu99 chroot_canon.c xmalloc.c xstrdup.c cache.c readlib.c -I. dl-cache.c -o ldconfig
  23. }
  24. do_install () {
  25. install -d ${D}/${bindir}/
  26. install ldconfig ${D}/${bindir}/
  27. }