cross-localedef-native_2.36.bb 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. SUMMARY = "Cross locale generation tool for glibc"
  2. HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
  3. SECTION = "libs"
  4. LICENSE = "LGPL-2.1-only"
  5. LIC_FILES_CHKSUM = "file://LICENSES;md5=1541fd8f5e8f1579512bf05f533371ba \
  6. file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
  7. file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
  8. file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
  9. require glibc-version.inc
  10. # Tell autotools that we're working in the localedef directory
  11. #
  12. AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
  13. inherit autotools
  14. inherit native
  15. FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
  16. SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
  17. git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef;protocol=https \
  18. \
  19. file://0001-localedef-Add-hardlink-resolver-from-util-linux.patch \
  20. file://0002-localedef-fix-ups-hardlink-to-make-it-compile.patch \
  21. \
  22. file://0010-eglibc-Cross-building-and-testing-instructions.patch \
  23. file://0011-eglibc-Help-bootstrap-cross-toolchain.patch \
  24. file://0012-eglibc-Resolve-__fpscr_values-on-SH4.patch \
  25. file://0013-eglibc-Forward-port-cross-locale-generation-support.patch \
  26. file://0014-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
  27. file://0019-Replace-echo-with-printf-builtin-in-nscd-init-script.patch \
  28. file://0021-timezone-Make-shell-interpreter-overridable-in-tzsel.patch \
  29. "
  30. # Makes for a rather long rev (22 characters), but...
  31. #
  32. SRCREV_FORMAT = "glibc_localedef"
  33. S = "${WORKDIR}/git"
  34. EXTRA_OECONF = "--with-glibc=${S}"
  35. # We do not need bash to run tzselect script, the default is to use
  36. # bash but it can be configured by setting KSHELL Makefile variable
  37. EXTRA_OEMAKE += "KSHELL=/bin/sh"
  38. CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
  39. do_install() {
  40. install -d ${D}${bindir}
  41. install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
  42. install -m 0755 ${B}/cross-localedef-hardlink ${D}${bindir}/cross-localedef-hardlink
  43. }