dhcp_4.4.3.bb 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. require dhcp.inc
  2. SRC_URI += "file://0001-define-macro-_PATH_DHCPD_CONF-and-_PATH_DHCLIENT_CON.patch \
  3. file://0002-dhclient-dbus.patch \
  4. file://0003-link-with-lcrypto.patch \
  5. file://0004-Fix-out-of-tree-builds.patch \
  6. file://0005-dhcp-client-fix-invoke-dhclient-script-failed-on-Rea.patch \
  7. file://0007-Add-configure-argument-to-make-the-libxml2-dependenc.patch \
  8. file://0009-remove-dhclient-script-bash-dependency.patch \
  9. file://0012-dhcp-correct-the-intention-for-xml2-lib-search.patch \
  10. file://0013-fixup_use_libbind.patch \
  11. file://0001-workaround-busybox-limitation-in-linux-dhclient-script.patch \
  12. "
  13. SRC_URI[md5sum] = "9076af4cc1293dde5a7c6cae7de6ab45"
  14. SRC_URI[sha256sum] = "0e3ec6b4c2a05ec0148874bcd999a66d05518378d77421f607fb0bc9d0135818"
  15. LDFLAGS:append = " -pthread"
  16. PACKAGECONFIG ?= "systemd"
  17. PACKAGECONFIG[bind-httpstats] = "--with-libxml2,--without-libxml2,libxml2"
  18. PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd"
  19. CFLAGS += "-fcommon"
  20. python dhcp_split_compat() {
  21. do_split_packages(d,
  22. root = '${libdir}',
  23. file_regex = r'^lib(.*)\.so\..*',
  24. output_pattern = '${PN}-lib%s',
  25. description = 'dhcp %s library',
  26. extra_depends = '',
  27. allow_links = True)
  28. }
  29. PACKAGES:remove = "dhcp-libs"
  30. PACKAGES_DYNAMIC = "^${PN}-lib.*"
  31. PACKAGE_PREPROCESS_FUNCS += "dhcp_split_compat"