spltool-native_1.0.0.bb 602 B

123456789101112131415161718192021222324252627282930
  1. DESCRIPTION = "Starfive Tools"
  2. inherit native
  3. BBCLASSEXTEND = "native"
  4. LICENSE = "CLOSED"
  5. LIC_FILES_CHKSUM = ""
  6. FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
  7. SRC_URI = "file://jh8100_cst.tar.gz"
  8. S = "${WORKDIR}/jh8100_cst"
  9. FILES:${PN} = "${bindir}/*"
  10. RDEPENDS:${PN} = "bash"
  11. do_compile() {
  12. oe_runmake -C ${S}
  13. }
  14. do_install() {
  15. install -d ${D}${bindir}
  16. install -d ${D}${bindir}/input_files/jh8100
  17. install -m 0755 ${S}/input_files/jh8100/scpbl_nor.cfg ${D}${bindir}/input_files/jh8100/scpbl_nor.cfg
  18. install -m 0755 ${S}/mkbif ${D}${bindir}
  19. install -m 0755 ${S}/create_hdr ${D}${bindir}
  20. }