opensbi_1.2.bb 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. SUMMARY = "RISC-V Open Source Supervisor Binary Interface (OpenSBI)"
  2. DESCRIPTION = "OpenSBI aims to provide an open-source and extensible implementation of the RISC-V SBI specification for a platform specific firmware (M-mode) and a general purpose OS, hypervisor or bootloader (S-mode or HS-mode). OpenSBI implementation can be easily extended by RISC-V platform or System-on-Chip vendors to fit a particular hadware configuration."
  3. HOMEPAGE = "https://github.com/riscv/opensbi"
  4. LICENSE = "BSD-2-Clause"
  5. LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=42dd9555eb177f35150cf9aa240b61e5"
  6. require opensbi-payloads.inc
  7. inherit autotools-brokensep deploy
  8. SRCREV = "6b5188ca14e59ce7bf71afe4e7d3d557c3d31bf8"
  9. SRC_URI = "git://github.com/riscv/opensbi.git;branch=master;protocol=https"
  10. S = "${WORKDIR}/git"
  11. EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= "
  12. # If RISCV_SBI_PAYLOAD is set then include it as a payload
  13. EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_image(d)}"
  14. EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_fdt(d)}"
  15. # Required if specifying a custom payload
  16. do_compile[depends] += "${@riscv_get_do_compile_depends(d)}"
  17. do_install:append() {
  18. # In the future these might be required as a dependency for other packages.
  19. # At the moment just delete them to avoid warnings
  20. rm -r ${D}/include
  21. rm -r ${D}/lib*
  22. rm -r ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/payloads
  23. }
  24. do_deploy () {
  25. install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOYDIR}/
  26. install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOYDIR}/
  27. install -m 755 ${D}/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOYDIR}/
  28. }
  29. addtask deploy before do_build after do_install
  30. FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_jump.*"
  31. FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_payload.*"
  32. FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*"
  33. COMPATIBLE_HOST = "(riscv64|riscv32).*"
  34. INHIBIT_PACKAGE_STRIP = "1"
  35. SECURITY_CFLAGS = ""