opensbi_%.bbappend 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. FORK:starfive-dubhe = "starfive-tech"
  2. BRANCH:starfive-dubhe = "starfive-v1.2-dubhe"
  3. SRCREV:starfive-dubhe = "8ce81d0fbcbb10d4ad9e924c8cd64925b79e0cb6"
  4. FORK:starfive-visionfive2 = "starfive-tech"
  5. BRANCH:starfive-visionfive2 = "master"
  6. SRCREV:starfive-visionfive2 = "c6a092cd80112529cb2e92e180767ff5341b22a3"
  7. FORK:starfive-jh8100 = "starfive-tech"
  8. BRANCH:starfive-jh8100 = "fpga-starfive-v1.2-jh8100-bmc-30Nov"
  9. SRCREV:starfive-jh8100 = "7cbdf359bb9d2f4c79c736fa92952a06a7740657"
  10. SRC_URI:starfive-dubhe = "\
  11. git://github.com/${FORK}/opensbi.git;protocol=https;branch=${BRANCH} \
  12. "
  13. SRC_URI:starfive-visionfive2 = "\
  14. git://github.com/${FORK}/opensbi.git;protocol=https;branch=${BRANCH} \
  15. file://visionfive2-uboot-fit-image.its \
  16. "
  17. SRC_URI:starfive-jh8100 = "\
  18. git://github.com/${FORK}/opensbi.git;protocol=https;branch=${BRANCH} \
  19. "
  20. SRC_URI:remove:nezha = "\
  21. file://0001-lib-utils-fdt-Require-match-data-to-be-const.patch \
  22. file://0002-lib-utils-timer-Add-a-separate-compatible-for-the-D1.patch \
  23. "
  24. EXTRA_OEMAKE:starfive-dubhe = "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= FW_OPTIONS=0 FW_TEXT_START=0x80100000 PLATFORM_DEFCONFIG=starfive_defconfig"
  25. EXTRA_OEMAKE:starfive-visionfive2 = "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= FW_TEXT_START=0x40000000"
  26. EXTRA_OEMAKE:starfive-jh8100 = "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= FW_OPTIONS=0 FW_TEXT_START=0x40000000 PLATFORM_DEFCONFIG=starfive_defconfig"
  27. DEPENDS:starfive-visionfive2 += "u-boot-tools-native dtc-native"
  28. do_deploy:append:starfive-visionfive2() {
  29. install -m 0644 ${WORKDIR}/visionfive2-uboot-fit-image.its ${DEPLOYDIR}/visionfive2-uboot-fit-image.its
  30. cd ${DEPLOYDIR}
  31. mkimage -f visionfive2-uboot-fit-image.its -A riscv -O u-boot -T firmware visionfive2_fw_payload.img
  32. }