coremark_1.0.bb 648 B

12345678910111213141516171819202122232425
  1. SUMMARY = "Coremark CPU benchmark"
  2. LICENSE = "Apache-2.0"
  3. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
  4. INHIBIT_PACKAGE_STRIP = "1"
  5. SRC_URI = "git://github.com/sifive/benchmark-coremark.git;protocol=https \
  6. file://0001-Add-Compiler-Flags-and-remove-exe-from-output.patch \
  7. "
  8. SRCREV = "4486de1f0afe9d6c1fa8dd63743e5751286f3d2f"
  9. S = "${WORKDIR}/git"
  10. TARGET_CC_ARCH += "${LDFLAGS}"
  11. EXTRA_OEMAKE += "'CC=${CC}' PORT_DIR=linux64"
  12. do_compile(){
  13. oe_runmake compile
  14. }
  15. do_install() {
  16. install -d ${D}${bindir}
  17. install -m 0755 coremark ${D}${bindir}
  18. }