gdb_10.1.bbappend 3.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
  2. SRCREV = "63a44e5923c859e99d3a8799fa8132b49a135241"
  3. BRANCH = "fsf-gdb-10.1-with-sim"
  4. S = "${WORKDIR}/git"
  5. SRC_URI = " git://github.com/riscv/riscv-binutils-gdb.git;branch=${BRANCH} \
  6. file://0004-RISC-V-Minor-cleanup-and-testcases-improvement-for-a.patch \
  7. file://0005-RISC-V-Don-t-allow-any-uppercase-letter-in-the-arch-.patch \
  8. file://0006-RISC-V-Add-zifencei-and-prefixed-h-class-extensions.patch \
  9. file://0007-RISC-V-Remove-the-unimplemented-extensions.patch \
  10. file://0008-RISC-V-Improve-the-version-parsing-for-arch-string.patch \
  11. file://0009-RISC-V-Support-to-add-implicit-extensions.patch \
  12. file://0010-RISC-V-Support-to-add-implicit-extensions-for-G.patch \
  13. file://0011-RISC-V-Fix-the-order-checking-for-Z-extension.patch \
  14. file://0012-RISC-V-Support-RVV-according-to-vector-spec-v1.0-dra.patch \
  15. file://0013-Extend-the-VL-nf-R-and-VS-nf-R-instruction-when-nf-i.patch \
  16. file://0014-Remove-Vector-indexed-instruction-when-EEW-128.patch \
  17. file://0015-Add-assembly-pseudo-instructions-vncvt.x.x.v.patch \
  18. file://0016-Update-the-vector-spec-version-tag-Version-1.0-draft.patch \
  19. file://0017-Added-reciprocal-and-reciprocal-square-root-estimate.patch \
  20. file://0018-Added-element-width-hint-to-whole-register-loads-sto.patch \
  21. file://0019-Update-the-vector-spec-version-tag-Version-1.0-draft.patch \
  22. file://0020-Added-vrgatherei16-instruction.patch \
  23. file://0021-Make-vlmul-bits-contiguous-in-vtype.patch \
  24. file://0022-RISC-V-Clarify-the-supported-versions-for-the-unrati.patch \
  25. file://0023-RISC-V-Convert-CSR-dwarf-numbers-to-gdb-register-num.patch \
  26. file://0024-RISC-V-Update-the-vector-mask-constraints.patch \
  27. file://0025-RISC-V-Add-the-missing-constraints-for-VL-nf-R-and-V.patch \
  28. file://0026-RISC-V-Fix-the-constraints-for-vector-mask-and-compr.patch \
  29. file://0027-RISC-V-Report-rvv-assembler-constraint-errors-in-det.patch \
  30. file://0028-RISC-V-Support-Zfh-standard-extension-for-half-preci.patch \
  31. file://0029-RISC-V-Support-.float16-directive-for-assembler.patch \
  32. file://0030-Set-default-version-of-ZFH-to-0.1.patch \
  33. file://0031-RISC-V-Add-assembly-pseudoinstructions-vneg.v-and-vf.patch \
  34. file://0032-RISC-V-Added-ordered-unordered-vector-indexed-instru.patch \
  35. file://0033-RISC-V-Rename-vncvt.x.x.v-to-vncvt.x.x.w.patch \
  36. file://0034-SiFive-Support-SiFive-CLIC-CSRs.patch \
  37. file://0035-SiFive-Support-SiFive-specific-cache-control-instruc.patch \
  38. file://0036-Initial-support-for-RISC-V-Bitmanip-Spec-0.92.patch \
  39. file://0037-RISC-V-Support-sub-extensions-of-B-for-march-parser.patch \
  40. file://0038-RISC-V-Remove-ld-testcases-which-should-be-better-to.patch \
  41. file://0039-RISC-V-Added-Removed-Updated-instructions-to-the-ris.patch \
  42. file://0040-RISC-V-Add-missing-zext.-hw-pseudo-instructions.patch \
  43. file://0041-RISC-V-Re-define-zba-zbb-zbc-and-zbs-extensions.patch \
  44. file://0042-RISC-V-Define-pseudo-rev-orc-zip-unzip-as-alias-inst.patch \
  45. file://0043-RISC-V-Add-testcases-for-ZBA-and-ZBB-instructions.patch \
  46. file://0044-RISC-V-Add-sext.-bh-and-zext.-bhw-pseudo-instruction.patch \
  47. file://0045-Fix-sim-build-since-op-match_func-have-more-argument.patch \
  48. file://0046-SiFive-Add-RNMI-CSRs-and-MNRET-instruction.patch \
  49. file://0047-RISC-V-Freeze-ZBA-ZBB-ZBC-to-0.93.patch \
  50. file://0048-fix-incorrect-shfli-and-unshfli-opcode.patch \
  51. file://0001-make-man-install-relative-to-DESTDIR.patch \
  52. file://0002-mips-linux-nat-Define-_ABIO32-if-not-defined.patch \
  53. file://0003-ppc-ptrace-Define-pt_regs-uapi_pt_regs-on-GLIBC-syst.patch \
  54. file://0004-Add-support-for-Renesas-SH-sh4-architecture.patch \
  55. file://0005-Dont-disable-libreadline.a-when-using-disable-static.patch \
  56. file://0006-use-asm-sgidefs.h.patch \
  57. file://0008-Change-order-of-CFLAGS.patch \
  58. file://0009-resolve-restrict-keyword-conflict.patch \
  59. file://0010-Fix-invalid-sigprocmask-call.patch \
  60. file://0011-gdbserver-ctrl-c-handling.patch \
  61. "