qemu-system-native_6.0.0.bb 1.0 KB

12345678910111213141516171819202122232425262728293031
  1. BPN = "qemu"
  2. inherit python3-dir
  3. require qemu-native.inc
  4. # As some of the files installed by qemu-native and qemu-system-native
  5. # are the same, we depend on qemu-native to get the full installation set
  6. # and avoid file clashes
  7. DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native bison-native"
  8. EXTRA_OECONF_append = " --target-list=${@get_qemu_system_target_list(d)}"
  9. PACKAGECONFIG ??= "fdt alsa kvm pie \
  10. ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer glx', '', d)} \
  11. "
  12. # Handle distros such as CentOS 5 32-bit that do not have kvm support
  13. PACKAGECONFIG_remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
  14. do_install_append() {
  15. install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
  16. # The following is also installed by qemu-native
  17. rm -f ${D}${datadir}/qemu/trace-events-all
  18. rm -rf ${D}${datadir}/qemu/keymaps
  19. rm -rf ${D}${datadir}/icons/
  20. # Install qmp.py to be used with testimage
  21. install -D ${S}/python/qemu/qmp.py ${D}${PYTHON_SITEPACKAGES_DIR}/qmp.py
  22. }