linux-starfive-dev.bbappend 2.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. FORK:starfive-dubhe = "starfive-tech"
  2. BRANCH:starfive-dubhe = "starfive-6.1-dubhe"
  3. SRCREV:starfive-dubhe = "0a9c9aa4208378d4da0cf13c6c5a3a92da370b26"
  4. FORK:starfive-visionfive2 = "starfive-tech"
  5. BRANCH:starfive-visionfive2 = "JH7110_VisionFive2_devel"
  6. SRCREV:starfive-visionfive2 = "d9eee31aaec51ade1641391836c1f07dd2151a4a"
  7. LINUX_VERSION ?= "6.1.20"
  8. LINUX_VERSION:starfive-dubhe = "6.1.20"
  9. LINUX_VERSION:starfive-visionfive2 = "5.15.0"
  10. LINUX_VERSION_EXTENSTION:append:starfive-dubhe = "-starlight"
  11. FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
  12. SRC_URI:starfive-dubhe = " \
  13. git://git@192.168.110.45/${FORK}/linux.git;protocol=ssh;branch=${BRANCH} \
  14. file://cpio.cfg \
  15. "
  16. SRC_URI:starfive-visionfive2 = " \
  17. git://github.com/${FORK}/linux.git;protocol=https;branch=${BRANCH} \
  18. file://vf2.cfg \
  19. "
  20. INITRAMFS_IMAGE_BUNDLE:starfive-dubhe = "${@oe.utils.conditional('ENABLE_INIT','1','1','',d)}"
  21. INITRAMFS_IMAGE:starfive-dubhe = "${@oe.utils.conditional('ENABLE_INIT','1','dubhe-image-initramfs','',d)}"
  22. INITRAMFS_IMAGE:starfive-visionfive2 = "core-image-minimal-initramfs"
  23. # Temporary remove the patch to update the kernel, will create new patches after that
  24. SRC_URI:append:starfive-dubhe = "${@oe.utils.conditional('ENABLE_EXT4','1','file://ext4.patch','',d)}"
  25. SRC_URI:append:starfive-dubhe = "${@oe.utils.conditional('ENABLE_UBI','1','file://ubi.patch','',d)}"
  26. SRC_URI:append:starfive-dubhe = "${@oe.utils.conditional('ENABLE_NFS','1','file://nfs.patch','',d)}"
  27. KBUILD_DEFCONFIG:starfive-dubhe = "starfive_dubhe_defconfig"
  28. KBUILD_DEFCONFIG:starfive-visionfive2 = "starfive_visionfive2_defconfig"
  29. COMPATIBLE_MACHINE = "(starfive-dubhe|starfive-visionfive2)"
  30. FILES:${KERNEL_PACKAGE_NAME}-base += "/usr/*"
  31. DEPENDS:starfive-visionfive2 += " u-boot-tools-native u-boot-starfive"
  32. do_deploy:append:starfive-visionfive2 () {
  33. # Create FitImage
  34. cd ${DEPLOY_DIR_IMAGE}
  35. rm -rf ${DEPLOY_DIR_IMAGE}/tmp
  36. mkdir ${DEPLOY_DIR_IMAGE}/tmp
  37. cp -P ${DEPLOYDIR}/* ${DEPLOY_DIR_IMAGE}/tmp/
  38. mkimage -A riscv -O linux -T ramdisk -n "Initial Ram Disk" -d core-image-minimal-initramfs-starfive-visionfive2.cpio.gz initramfs.img
  39. mkimage -f ${DEPLOY_DIR_IMAGE}/visionfive2-fit-image.its ${DEPLOY_DIR_IMAGE}/starfiveu.fit
  40. }
  41. do_compile[nostamp] = "1"