qspi-ubifs-image_0.1.bb 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. SUMMARY = "QSPI Ubifs Image Creator"
  2. DESCRIPTION = "Recipe to create a QSPI Ubifs Image"
  3. LICENSE = "CLOSED"
  4. inherit core-image
  5. DEPENDS += "opensbi deploy-bootfiles quilt quilt-native"
  6. LIC_FILES_CHKSUM = ""
  7. IMAGE_FSTYPES = "ubi ubifs qspi_ubifs"
  8. MKUBIFS_ARGS = "-m 1 -e 65408 -c 26876"
  9. UBINIZE_ARGS = " -p 64KiB -m 1"
  10. IMAGE_ROOTFS_SIZE ?= "8192"
  11. IMAGE_FEATURES += "allow-empty-password empty-root-password"
  12. #IMAGE_INSTALL += "mtd-utils mtd-utils-ubifs kernel-modules"
  13. IMAGE_INSTALL += "\
  14. packagegroup-starfive-essentials \
  15. packagegroup-starfive-dubhe-essentials \
  16. "
  17. TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"
  18. IMAGE_FEATURES:remove = "dbg-pkgs"
  19. export IMAGE_BASENAME = "qspi-ubifs"
  20. do_image_qspi_ubifs[depends] += "\
  21. deploy-bootfiles:do_deploy \
  22. opensbi:do_deploy \
  23. virtual/kernel:do_deploy \
  24. "
  25. IMAGE_TYPEDEP:qspi_ubifs = "ubi"
  26. IMAGE_CMD:qspi_ubifs () {
  27. dd if=${DEPLOY_DIR_IMAGE}/bootcode.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=0 count=128
  28. dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=128 count=1
  29. dd if=${DEPLOY_DIR_IMAGE}/dubhe90_fpga_ubi.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=129 count=255
  30. dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=32 seek=384 count=1048192
  31. dd if=${IMGDEPLOYDIR}/qspi-ubifs-starfive-dubhe.ubi of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-90-qspi-ubifs-image.bin bs=64KiB seek=512
  32. dd if=${DEPLOY_DIR_IMAGE}/bootcode.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=32 seek=0 count=128
  33. dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=32 seek=128 count=1
  34. dd if=${DEPLOY_DIR_IMAGE}/dubhe80_fpga_ubi.dtb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=32 seek=129 count=255
  35. dd if=${DEPLOY_DIR_IMAGE}/fw_payload.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=32 seek=384 count=1048192
  36. dd if=${IMGDEPLOYDIR}/qspi-ubifs-starfive-dubhe.ubi of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-80-qspi-ubifs-image.bin bs=64KiB seek=512
  37. }