qspi-image_0.1.bb 844 B

12345678910111213141516171819202122232425
  1. SUMMARY = "QSPI Image Creator"
  2. DESCRIPTION = "Recipe to create a QSPI Image"
  3. LICENSE = "CLOSED"
  4. inherit core-image
  5. DEPENDS = "deploy-bootfiles"
  6. LIC_FILES_CHKSUM = ""
  7. IMAGE_FSTYPES = "qspi"
  8. do_rootfs[depends] += "dubhe-image-initramfs:do_rootfs"
  9. do_image[depends] += "\
  10. deploy-bootfiles:do_deploy \
  11. u-boot-starfive:do_deploy \
  12. "
  13. IMAGE_CMD:qspi(){
  14. dd if=${DEPLOY_DIR_IMAGE}/bootcode.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-qspi-tftpboot.bin bs=32 seek=0 count=128
  15. dd if=${DEPLOY_DIR_IMAGE}/bootjump.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-qspi-tftpboot.bin bs=32 seek=128 count=128
  16. dd if=${DEPLOY_DIR_IMAGE}/u-boot-spl.bin of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-qspi-tftpboot.bin bs=32 seek=256 count=8192
  17. dd if=${DEPLOY_DIR_IMAGE}/u-boot.itb of=${DEPLOY_DIR_IMAGE}/starfive-dubhe-qspi-tftpboot.bin bs=32 seek=8448 count=32768
  18. }