dhrystone_2.1.bb 595 B

12345678910111213141516171819202122232425
  1. SUMMARY = "Dhrystone CPU benchmark"
  2. LICENSE = "PD"
  3. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851"
  4. INHIBIT_PACKAGE_STRIP = "1"
  5. SRC_URI = "git://github.com/sifive/benchmark-dhrystone.git \
  6. file://0001-Edit-Makefile-to-add-compiler-flags.patch \
  7. "
  8. SRCREV = "0ddff533cc9052c524990d5ace4560372053314b"
  9. S = "${WORKDIR}/git"
  10. TARGET_CC_ARCH += "${LDFLAGS}"
  11. EXTRA_OEMAKE += "'CC=${CC}'"
  12. do_compile(){
  13. oe_runmake dhrystone
  14. }
  15. do_install() {
  16. install -d ${D}${bindir}
  17. install -m 0755 dhrystone ${D}${bindir}
  18. }