cross-localedef-native_2.35.bb 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. SUMMARY = "Cross locale generation tool for glibc"
  2. HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
  3. SECTION = "libs"
  4. LICENSE = "LGPL-2.1"
  5. LIC_FILES_CHKSUM = "file://LICENSES;md5=1541fd8f5e8f1579512bf05f533371ba \
  6. file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
  7. file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
  8. file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
  9. require glibc-version.inc
  10. # Tell autotools that we're working in the localedef directory
  11. #
  12. AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
  13. inherit autotools
  14. inherit native
  15. FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
  16. SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
  17. git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef;protocol=https \
  18. \
  19. file://0001-localedef-Add-hardlink-resolver-from-util-linux.patch \
  20. file://0002-localedef-fix-ups-hardlink-to-make-it-compile.patch \
  21. \
  22. file://0017-timezone-re-written-tzselect-as-posix-sh.patch \
  23. file://0018-Remove-bash-dependency-for-nscd-init-script.patch \
  24. file://0019-eglibc-Cross-building-and-testing-instructions.patch \
  25. file://0020-eglibc-Help-bootstrap-cross-toolchain.patch \
  26. file://0021-eglibc-Resolve-__fpscr_values-on-SH4.patch \
  27. file://0022-eglibc-Forward-port-cross-locale-generation-support.patch \
  28. file://0024-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
  29. file://0001-Add-array_length-support.patch \
  30. "
  31. # Makes for a rather long rev (22 characters), but...
  32. #
  33. SRCREV_FORMAT = "glibc_localedef"
  34. S = "${WORKDIR}/git"
  35. EXTRA_OECONF = "--with-glibc=${S}"
  36. CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
  37. do_install() {
  38. install -d ${D}${bindir}
  39. install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
  40. install -m 0755 ${B}/cross-localedef-hardlink ${D}${bindir}/cross-localedef-hardlink
  41. }