gcc-source_10.2.bbappend 4.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
  2. SRC_URI += " \
  3. file://0002-testsuite-Require-gnu-tm-support-for-pr94856.C.patch \
  4. file://0003-RISC-V-Add-shorten_memrefs-pass.patch \
  5. file://0004-RISC-V-Update-march-parser.patch \
  6. file://0005-RISC-V-Handle-implied-extension-for-march-parser.patch \
  7. file://0006-Fix-alignment-for-local-variable-PR90811.patch \
  8. file://0007-RISC-V-Optimize-si-to-di-zero-extend-followed-by-lef.patch \
  9. file://0008-RISC-V-Make-__divdi3-handle-div-by-zero-same-as-hard.patch \
  10. file://0009-RISC-V-Normalize-arch-string-in-driver-time.patch \
  11. file://0010-RISC-V-Preserve-arch-version-info-during-normalizing.patch \
  12. file://0011-RISC-V-Handle-multi-letter-extension-for-multilib-ge.patch \
  13. file://0012-testsuite-Adjust-gfortran.dg-pr95690.f90-line-number.patch \
  14. file://0013-RISC-V-fix-a-typo-in-riscv.h.patch \
  15. file://0014-Fix-build-failure-with-zstd-versio9n-1.2.0-or-older.patch \
  16. file://0015-RISC-V-Define-__riscv_cmodel_medany-for-PIC-mode.patch \
  17. file://0016-RISC-V-Add-support-for-mcpu-option.patch \
  18. file://0017-RISC-V-Handle-implied-extension-in-multilib-generato.patch \
  19. file://0018-RISC-V-Extend-syntax-for-the-multilib-generator.patch \
  20. file://0019-RISC-V-Refine-riscv_parse_arch_string.patch \
  21. file://0020-RISC-V-Add-configure-option-with-multilib-generator-.patch \
  22. file://0021-RISC-V-Check-multiletter-extension-has-more-than-1-l.patch \
  23. file://0022-RISC-V-Mark-non-export-symbol-static-and-const-in-ri.patch \
  24. file://0023-RISC-V-Enable-ifunc-if-it-was-supported-in-the-binut.patch \
  25. file://0024-RISC-V-Handle-implied-extension-in-canonical-orderin.patch \
  26. file://0025-RISC-V-Support-zicsr-and-zifencei-extension-for-marc.patch \
  27. file://0026-RISC-V-Support-version-controling-for-ISA-standard-e.patch \
  28. file://0027-Fix-print_multilib_info-when-default-arguments-appea.patch \
  29. file://0028-RISC-V-Always-define-MULTILIB_DEFAULTS.patch \
  30. file://0029-RISC-V-Drop-some-commited-accidentally-code.patch \
  31. file://0030-RISC-V-Canonicalize-with-arch.patch \
  32. file://0031-RISC-V-Explicitly-call-python-when-using-multilib-ge.patch \
  33. file://0032-Add-TARGET_COMPUTE_MULTILIB-hook-to-override-multi-l.patch \
  34. file://0033-RISC-V-Implement-TARGET_COMPUTE_MULTILIB.patch \
  35. file://0034-PR-target-97682-Fix-to-reuse-t1-register-between-cal.patch \
  36. file://0035-soft-fp-Support-more-fp16-operation.patch \
  37. file://0036-soft-fp-Implement-more-soft-fp16-functions.patch \
  38. file://0037-RISC-V-Support-zfh-extension.patch \
  39. file://0038-RISC-V-Set-default-version-for-zfh-to-0.1.patch \
  40. file://0039-Add-VECTOR_TUPLE_MODES_WITH_PREFIX-in-genmodes.patch \
  41. file://0040-RISC-V-Support-vector-intrinsic-functions.patch \
  42. file://0041-riscv-bitmanip-Support-for-B-ext.patch \
  43. file://0042-SiFive-CLIC-patches-for-preemptible-and-stack-swappi.patch \
  44. file://0043-Implement-compact-code-model.patch \
  45. file://0044-Adjust-testcase-for-compact-code-model.patch \
  46. file://0045-WORKAROUND-Do-not-define-MULTILIB_DEFAULTS.patch \
  47. file://0046-RISC-V-Handle-more-multi-lib-option-than-arch-abi.patch \
  48. file://0047-RISC-V-Fix-python3-compatibility-for-multilib-genera.patch \
  49. file://0048-RISC-V-Move-class-riscv_subset_list-and-riscv_subset.patch \
  50. file://0049-RISC-V-Implement-new-style-of-architecture-extension.patch \
  51. file://0050-RISC-V-Remove-duplicated-define-for-zfh.patch \
  52. file://0051-Fix-zext.w-pattern.patch \
  53. file://0052-riscv-bitmanip-Fix-the-operand-order-of-addu.w.patch \
  54. file://0053-Fix-MacOS-build.patch \
  55. file://0054-Update-asm-pattern-to-RVB-0.93.patch \
  56. file://0055-Bump-version-of-RVB-to-0.93.patch \
  57. file://0056-Fix-match_score-for-other-cond.patch \
  58. file://0057-Fix-riscv_check_other_cond-for-non-multi-lib-build.patch \
  59. file://0058-Add-more-comment-for-riscv_check_other_cond.patch \
  60. file://0059-Do-not-install-riscv_vector.h-and-riscv_vector_itr.h.patch \
  61. file://0060-Avoid-to-use-same-temp-register-to-adjust-stack-poin.patch \
  62. file://0060-Initial-support-for-0.94-Bitmap.patch \
  63. file://0061-Remove-unsupported-bext.w-in-gcc.patch \
  64. file://0001-Yocto-patch-for-arch-canonicalize-to-use-python3.patch \
  65. "
  66. EXTRA_OECONF_append_riscv64 = " --with-arch=rv64gcb CFLAGS_FOR_TARGET="-O2 -mcmodel=medany" CXXFLAGS_FOR_TARGET="-O2 -mcmodel=medany""