core-image-minimal.bbappend 592 B

1234567891011121314
  1. DEPENDS += " opensbi starfive-tool-native u-boot-tools-native dtc-native"
  2. IMAGE_INSTALL += "helloworld coremark dhrystone perf gdb gdbserver util-linux ethtool bmap-tools systemd-analyze"
  3. # Generate SD Card image and eMMC image
  4. # - Using spl_tool to fix img header to boot from eMMC
  5. do_vf2_sd (){
  6. cd ${IMGDEPLOYDIR}
  7. bmaptool copy core-image-minimal-starfive-visionfive2.wic.gz ${DEPLOY_DIR_IMAGE}/starfive-visionfive2-core-image-minimal.img
  8. spl_tool -i -f ${DEPLOY_DIR_IMAGE}/starfive-visionfive2-core-image-minimal.img
  9. }
  10. IMAGE_POSTPROCESS_COMMAND:starfive-visionfive2 += "do_vf2_sd;"