core-image-starfive-extra.bb 711 B

123456789101112131415161718192021222324252627282930313233343536
  1. SUMMARY = "A StarFive image with additional packages."
  2. require sd-image.inc
  3. DEPENDS += " opensbi u-boot-tools-native dtc-native"
  4. IMAGE_INSTALL = "\
  5. packagegroup-core-boot \
  6. ${CORE_IMAGE_EXTRA_INSTALL} \
  7. bmap-tools \
  8. systemd-analyze \
  9. e2fsprogs-resize2fs \
  10. parted \
  11. ldd \
  12. file \
  13. git \
  14. texinfo \
  15. libcheck \
  16. packagegroup-core-buildessential \
  17. packagegroup-starfive-c \
  18. packagegroup-starfive-essentials \
  19. nodejs \
  20. nodejs-npm \
  21. i3c-tools \
  22. "
  23. TOOLCHAIN_TARGET_TASK += "packagegroup-starfive-toolchain"
  24. IMAGE_LINGUAS = " "
  25. LICENSE = "MIT"
  26. inherit core-image
  27. IMAGE_ROOTFS_SIZE ?= "8192"
  28. IMAGE_ROOTFS_EXTRA_SPACE:append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "", d)}"