muparser_2.3.2.bb 589 B

12345678910111213141516171819202122232425
  1. SUMMARY = "Fast Math Parser Library"
  2. HOMEPAGE = "http://beltoforion.de/article.php?a=muparser"
  3. LICENSE = "BSD-2-Clause"
  4. LIC_FILES_CHKSUM = "file://License.txt;md5=98f3ad1a0193387fc84b0101833605c8"
  5. SRC_URI = " \
  6. git://github.com/beltoforion/muparser.git;branch=master;protocol=https \
  7. file://run-ptest \
  8. "
  9. SRCREV = "207d5b77c05c9111ff51ab91082701221220c477"
  10. PV = "2.3.2"
  11. S = "${WORKDIR}/git"
  12. inherit cmake pkgconfig ptest
  13. EXTRA_OECMAKE = "-DENABLE_SAMPLES=OFF"
  14. do_install_ptest() {
  15. cp -rf ${B}/t_ParserTest ${D}${PTEST_PATH}
  16. }
  17. RDEPENDS:${PN}-ptest += " \
  18. cmake \
  19. "